В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Янрей
Янрей
08.06.2020 14:10 •  Информатика

Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами. примеры входные данные 6 1 2 3 4 5 6 выходные данные 1 4

Показать ответ
Ответ:
lida20171
lida20171
02.10.2020 12:46
Program a;
var i,n,c: integer;
mas1,mas2 : array[1..10000] of integer;
begin   c:=1;  
write('размер массива = ');
read (n); 
writeln('элементы массива: ');   
for i:=1 to n do    begin   
read (n);   
if (n>0) and (n<=10000) then begin    
mas1[c]:=n;   
inc(c);   
end;   
end;  
n:=1;  
writeln('Выходные данные: ');   
i:=1; 
while i<=(c-1) do begin   
mas2[n]:=mas1[i];                      
inc(n);   
i := i + 3;   
end;
for i:=1 to n-1 do    
write (mas2[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота