В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
частник
частник
02.02.2022 11:16 •  Информатика

Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до 10 в программе Phyton

Показать ответ
Ответ:
КамбэкBTS
КамбэкBTS
07.02.2022 01:10

k = 0

for n in range(0,11,2):

   k += n

print(k)

0,0(0 оценок)
Ответ:
reginа111222333
reginа111222333
07.02.2022 01:10

Первый :

s = 0

for k in range(1,11):

   if k % 2 ==0:

       s += k

print(s)

Второй :

s = 0

for k in range(1,11):

   s += k*((k+1)%2)

print(s)

Третий :

print(sum([ k*((k+1)%2) for k in range(1,11)]))

*Четвертый :

print(sum([ k for k in range(0,11, 2)])) - подсказал второй ответ.

**Оказывается есть пятый, самый легкий :

print(sum(range(0,11,2)))  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота