В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kunakovdp06u5r
kunakovdp06u5r
27.12.2020 13:28 •  Информатика

Напишите программу, которая выполняет инверсию битов в символьной строке: заменяет все нули на единицы, а единицы на нули. Паскаль

Показать ответ
Ответ:
Lena3411
Lena3411
08.12.2021 18:08

37

Объяснение:

На графе есть пункты, которые соединены с соседними 2 дорогами, а есть, которые 3 дорогами.

Разобъём их на группы и соотнесём буквы с возможными пунктами из таблицы.

3 дороги: А, В, Г, Д, Е, Ж и возможные пункты для них из таблицы: 2, 3, 5, 6, 7, 8 (смотрим на количество звездочек или по строкам или по столбцам)

2 дороги: Б, Ж, И и возможные пункты для них из таблицы: 1, 4, 9

Предположим, что пункту Б соответствует пункт 9 из таблицы, тогда пункт 9 должен быть связан с 2 пунктами из группы, где 3 дороги. Пункт 9 связан с пунктами 2 и 4, но только пункту 2 соответствуют 3 дороги. Значит предположение неверное.

Предположим, что пункту Б соответствует пункт 1 из таблицы, тогда пункт 1 должен быть связан с 2 пунктами из группы, где 3 дороги. Пункт 1 связан с пунктами 5 и 6, оба эти пункта связаны с соседними 3-я дорогами. Значит предположение верное.

Предположим, что пункту А соответствует пункт 5 из таблицы, тогда пункт 5 должен быть связан с 2 пунктами из группы, где 3 дороги, не считая пункта 1. Пункт 5 связан с пунктами 3 и 8, оба эти пункта связаны с соседними 3-я дорогами. Значит предположение верное.

Предположим, что пункту Г соответствует пункт 8 из таблицы, тогда пункт 8 должен быть связан с 2 пунктами из группы, где 3 дороги, не считая пункта 5. Пункт 8 связан с пунктами 3 и 4, но только пункту 3 соответствуют 3 дороги. Значит предположение неверное.

Предположим, что пункту Г соответствует пункт 3 из таблицы, тогда пункт 3 должен быть связан с 2 пунктами из группы, где 3 дороги, не считая пункта 5. Пункт 3 связан с пунктами 7 и 8, оба эти пункта связаны с соседними 3-я дорогами. Значит предположение верное.

Мы установили, что пункту Г может соответствовать пункт 3.

Рассуждая аналогично можно установить, что пункту Д может соответствовать пункт 7.

0,0(0 оценок)
Ответ:
valeriargavina
valeriargavina
25.08.2021 18:34

Ну вот примерно такое. Правда игра на 1 человека.

import time

name = raw_input ("Как вас зовут?")

print ("Приветствую, %s.") % name

age = raw_input ("Сколько вам лет?")

print ("Начнём же!")

print ("Приветствую, %s.") % (name)

print ("Сегодня у нас проходит игра Правда Или Действие. Если хотите выбрать правду напишите 't' если же действие, то напишите 'd'.")

truth_or_dare = raw_input ("Что вы выбираете?")

while True:

   if truth_or_dare == "t":

       print ("Расскажите мне свой секрет.")

       truth = raw_input ("Какой ваш секрет?")

       print ("Надо это запостить везде")

       time.sleep(2)

       break

   elif truth_or_dare == "d":

       print ("Загадываю тебе уйти отсюда")

       print ("Прощай")

       time.sleep(2)

       break

   else:

       print ("Так как вы ничего не выбрали игра завершилась")

       break

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота