В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая выводит на консоль простые числа в промежутке от [1, 100]. На Яве.

Показать ответ
Ответ:
ep1cook1e
ep1cook1e
15.06.2021 16:19

У меня в папках где-то этот код запропастился.

Везло, везло, наконец-то нашла задачу для решения которого требуется использоватать Java!

public class primeNumber {

   public static void main(String args[]) {

     

//Обьявление числа, с которого начнётся подчёт простых чисел

     int diapazon = 2;

     

//Число 2 движется к 100, через  каждый полный круг увеличивается на единицу  

     for (; diapazon<=100; diapazon++) {

//Обьявление переменной типа логического, проверяющее "простоту" числа

         boolean isPrime = true;

//Под-число "i", обязательно меньшее переменной diapazon, делится на diapazon

         for(int i = 2; i<diapazon; i++) {

//Если под-число делится хоть на какую-то цифру кроме себя, то "isPrime" — равно false, и цикл продолжается до тех пор, пока не найдёт простое число

             if(diapazon%i == 0) {

                 isPrime = false;

                 break;

             }

         }

//В противном случае — isPrime равно "true"

     if(isPrime) {

         System.out.println(diapazon);

     }

   }

}

}

0,0(0 оценок)
Ответ:
Yasha1221
Yasha1221
15.06.2021 16:19

for(int i = 2; i <= 100; i ++){

           boolean isPrime = true;

           for(int j = 2; j < i; j++){

               if(i % j == 0){

                   isPrime = false;

                   break;

               }

           }

           if(isPrime){

               System.out.println(i);

           }

       }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота