В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
katyarakushina03
katyarakushina03
28.12.2020 19:21 •  Информатика

Напишите программу, которая выводит все простые числа в диапазоне от 2 до n ( n заранее неизвестно). входные данные входная строка содержит целое число n . выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные 20 выходные данные 2 3 5 7 11 13 17 19

Показать ответ
Ответ:
невидома
невидома
26.08.2020 10:21
Var
A,N,d:integer;
Begin
Write('N = ');ReadLn(N);
For N:= 2 to N do
    Begin
    d:=0;
    A:=2;
    Repeat
    if N mod A = 0 then d:=d+1;
    A:=A+1
    Until A>Sqrt(N)+1;
    if d = 0 then Write(N,' ')
    End
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота