В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Vikusya18101
Vikusya18101
17.09.2021 23:48 •  Информатика

Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [10,500] и выводит его на экран. После этого на экран выводятся изменённый массив A[i] четное, то выводится 2*A[i], иначе A[i]+1

Показать ответ
Ответ:
NastushaJol
NastushaJol
10.03.2022 09:10

from random import randint

N = 10

A = [0]*N

print("Массив: " )

for i in range(N):

  A[i] = randint(100,500)

  print(A[i])

print()

for i in range(N):

   print(A[i]*2)

else:

   print(A[i]+1)

Объяснение чесн не думаю что она на все 100 праивльно но потянет

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота