В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Weterotog
Weterotog
25.03.2022 09:43 •  Информатика

Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы вводим 0. Программа должна вывести количество введенных чисел и среднее значение. питон

Показать ответ
Ответ:
розасит2006
розасит2006
24.03.2021 19:50

N = int(input())

s = 0

k = 0

sr = 0

while N != 0:

   s += N

   k += 1

   N = int(input())

sr = s/k

print('Количество введённых чисел - ',k)

print('Среднее арифметическое введённых чисел = ',sr)


Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы в
0,0(0 оценок)
Ответ:
Klaro555
Klaro555
24.03.2021 19:50

//Python 3.8.3

from typing import Callable, Any, Iterable

import statistics

def ReadSeqIntWhile(predicate: Callable[[Any], bool]) -> Iterable[Any]:

   temp = int(input())

   while(predicate(temp)):

       yield temp  

       temp = int(input())

def main():

   sequence = list(ReadSeqIntWhile(lambda p: p != 0))

   print(f"numbers count: {len(sequence)}, average value: {statistics.mean(sequence)}")

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота