В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kosahevaluba
kosahevaluba
04.08.2021 15:09 •  Информатика

Напишите программу, которая запрашивает у пользователя два целых числа a и b. С цикла for, посчитайте сумму всех чисел в диапазоне от числа a до числа b включительно, стоящие через одно. И выведите их среднее арифметическое. В задании не используйте условный оператор if, просто правильно пропишите range()

Например:

Входные данные:

-3

5

Выходные данные:

1.0

Показать ответ
Ответ:
TamaraPanova63
TamaraPanova63
22.07.2022 17:49

a = []

n = int(input("Начало: "))

x = int(input("Конец: "))

for i in range(n,x+1):

   a.append(i)

print((sum(a))/len(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота