В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yanaskazka777
yanaskazka777
07.05.2020 22:41 •  Информатика

Напишите программу, которая запрашивает ввести несколько слов с клавиатуры, а затем определяет длину самого короткого слова в строке.

Показать ответ
Ответ:
Aelly
Aelly
08.02.2022 04:13

import turtle

from math import tan, sqrt, pi

def prepare(x, y, color):

   turtle.penup()

   turtle.goto(x, y)

   turtle.pendown()

   turtle.color(color)

   turtle.begin_fill()

def draw_polygon(num_sides, side_length):

   angle = 360.0 / num_sides

   for i in range(num_sides):

       turtle.forward(side_length)

       turtle.right(angle)

   turtle.end_fill()

def calc_s(num_sides, side_length):

   return num_sides * side_length ** 2 / (4 * tan(pi/num_sides))

def calc_side(square):

   return sqrt(4 * square * tan(pi/num_sides) / num_sides)

turtle.hideturtle()

turtle.speed(10)

colors = ['red', 'green', 'blue', 'cyan', 'magenta', 'black', 'yellow', 'pink', 'brown']

xcoords = [0, 150, -150, 150, -150, 270, -270, 270, -270]

ycoords = [0, 150, -150, -150, 150, 270, -270, -270, 270]

squares = []

numsides = []

for i in range(9):

   num_sides = i + 3

   square = round(calc_s(num_sides, 100), 2)

   side_length = round(calc_side(10000), 3)

   squares.append(square)

   numsides.append(num_sides)

   print("Углов:", num_sides, "была площадь:", square, "стала длина грани:", side_length,

         "изменение в", round(side_length/100, 2), "раз")

   prepare(xcoords[i], ycoords[i], colors[i])

   draw_polygon(num_sides, side_length)

turtle.exitonclick()

print("Список количество углов:", numsides, end="")

print("Список площади:", squares)

Объяснение:

0,0(0 оценок)
Ответ:
isxakovravil82p0c2e4
isxakovravil82p0c2e4
18.02.2021 16:26

№1

Служби Інтернету

З Інтернету кожна людина отримує для себе цікаві та корисні відомості. Готуючись до уроку української літератури, учні шукають літературні твори. Когось цікавлять результати футбольних матчів, інших - поради з утримання домашніх тварин. Хтось хоче замовити через Інтернет квитки на літак, а хтось — подивитися цікаве відео. Багато людей використовують Інтернет для спілкування - це листування, обмін повідомленнями в реальному часі, мережні ігри тощо.

Різні потреби людей обслуговують різні служби Інтернету. Служб Інтернету багато, їх перелік постійно поповнюється.

№2 Протоко́л передава́ння да́них — набір угод інтерфейсу логічного рівня, які визначають обмін даними між різними програмами.

№3 Кабель провайдера, який заходить в квартиру або офіс, підключається тільки до одного пристрою – наприклад, стаціонарного ПК. Якщо користувачів багато, необхідно придбати роутер. Інтернет буде надходити на роутер, а той розділить його між користувачами. Дані в інтернеті передаються у вигляді пакетів, які направляються оптимальним маршрутом з можливих. У цьому відмінність інтернету від телефонної мережі. Спеціальне Подбає, щоб пакет з даними відправився по робочому маршруту навіть у випадку, якщо на шляху проходження виникли проблеми.

№4 Domain Name System, DNS) — ієрархічна розподілена система перетворення імені хоста (комп'ютера або іншого мережевого пристрою) в IP-адресу. Кожен комп'ютер в Інтернеті має свою власну унікальну адресу — число, яке складається з чотирьох (у протоколі IPv4) або шістнадцяти (у протоколі IPv6) байтів.

№5 До числа послуг, які надають провайдери можуть входити: доступ до інтернету по комутованому лініям надійного зв'язку надання дискового простору для зберігання та забезпечення роботи сайтів (хостинг); ... розташування обладнання клієнтів на власних технічних потужностях та лініях зв'язку (колокація);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота