Напишите программу: мальчик саша учится в школе ш, одна из особенностей которой состоит в том что на уроках в ней ставят только двойки и пятёрки. саша заранее узнал, на каких уроках языка он получит 2, а на каких — 5. саша идёт на деревянную медаль, и поэтому ему надо получить оценку за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть хотя бы одна оценка). он хочет прогулять часть уроков, чтобы исправить ситуацию (если саша прогуливает урок, он не получает никакой оценки). но саша — добропорядочный мальчик, поэтому он хочет прогулять минимальное количество уроков. ему.
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
int main(void)
{int n,mark,count2=0,count5=0,res;
printf("Enter number of classes:");
scanf("%d",&n);
printf("Enter marks:\n");
for(int i=0;i<n;i++)
{scanf("%d",&mark);
if(mark==5) count5++;
if(mark==2)
count2++;}
res=count2-count5;
if (res<0)
res=0;
if (count5==0)
printf("Impossible");
else
printf("%d",res);
return 0;}
Пример ввода:
3
5
2
2
Пример вывода:
1