В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
antoshkaromanov
antoshkaromanov
17.06.2022 04:54 •  Информатика

Напишите программу. Массив состоит из 5 элементов. Его необходимо заполнить рандомными числами от -40 до 40. Найти сумму четных индексов массива (номера четных домиков). Вывести эти элементы и сумму.

Показать ответ
Ответ:
Марусяняша
Марусяняша
14.04.2021 18:05

import random

num = []

result = 0

for i in range(5):  #Заполняем список рандомными числами

   value = random.randint(-40, 40)

   num.append(value)

for i in num:   #Находим сумму четных цифр

   if i % 2 == 0:

       result += i

print(num)

print(result)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота