В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nekrasska
nekrasska
07.01.2023 16:51 •  Информатика

Напишите программу на Паскаль, которая во всех нечётных элементах данного набора изменяет порядок цифр на противоположный. В первой строке входных данных записано натуральное число N (1<=N<=100)- количество чисел в наборе. Во второй строке записано N чисел. Все числа не превосходят 10^9 .

Показать ответ
Ответ:
жека596
жека596
22.12.2022 07:18
Персональные компьютеры PC сегодня стали незаменимыми человека во всех без исключения сферах человеческой деятельности. На компьютерах рассчитывают заработную плату и объем урожая, рисуют графики движения товаров и изменения общественного мнения, проектируют атомные реакторы и ботинки.

Слово “компьютер” означает “вычислитель”. Потребность в автоматизации обработки данных, в том числе вычислений, возникла очень давно. В настоящее время индустрия производства компьютерного железа и программного обеспечения является одной из наиболее важных сфер экономики развитых и развивающихся стран. Причины стремительного роста индустрии персональных компьютеров: 
невысокая стоимость; 
сравнительная выгодность для многих деловых применений; 
простота использования; 
возможность индивидуального взаимодействия с компьютеров без посредников и ограничений; 
высокие возможности по переработке, хранению и выдаче информации; 
высокая надежность, простота ремонта и эксплуатации; 
компьютерное железо адаптивно к особенностям применения компьютеров; 
наличие программного обеспечения, охватывающего практически все сферы человеческой деятельности, а также мощных систем для разработки нового программного обеспечения. 
0,0(0 оценок)
Ответ:
akirienko2003
akirienko2003
29.11.2021 12:22

ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота