В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
darya2401
darya2401
07.05.2021 08:18 •  Информатика

напишите программу на паскале, чтобы найти нод 2 и 3 чисел и с объяснениями (зачем использовать именно этот цикл, по типу таких)

Показать ответ
Ответ:
mashkabaku
mashkabaku
09.06.2023 16:18

#include <iostream>

#include <string.h>

using namespace std;

#define MAX 128

char str[MAX], alf[MAX];

int main()

{

puts("Input name: ");

gets(str);

strlwr(str);

for(int i = 0; i <= 'z' - 'a'; i++)  

 alf[i] = 'a' + i;

for(int i = 0; i < strlen(str); i++)

 if ((str[i] >= 'a') && (str[i] <= 'z'))

  alf[str[i] - 'a'] = '0';

cout << "Letters that are not in the name: ";

for(int i = 0; i <= 'z' - 'a'; i++)  

 if (alf[i] != '0')

  cout << alf[i] << " ";

return 0;

}

0,0(0 оценок)
Ответ:
лошадь20
лошадь20
18.07.2022 19:52

#include <iostream>

using namespace std;

int main()

{

 double x, y, z;   // объявления переменных для длин сторон

 bool b;           // логическая переменная, true - построить можно, false - построить нельзя

 setlocale(LC_ALL, "Russian");

 cout << "Введите длины сторон треугольника: ";

 cin >> x >> y >> z;         // ввод длин сторон

 b = false;                  // начальное значение для b

 if (x >= y && x >= z)       // если x самая длинная сторона треугольника

   b = x < y + z;            // проверяем, что длинная сторона меньше суммы двух других сторон, результат сохраняем в b

 else if (y >= x && y >= z)  // если y самая длинная сторона треугольника

   b = y < x + z;            // проверка та же

 else if (z >= x && z >= y)  // если z самая длинная сторона треугольника

   b = z < x + y;            // проверка та же

 if (b)                      // смотрим b и выводим соответствующее сообщение

   cout << "\nТреугольник построить можно\n";

 else

   cout << "\nТреугольник построить нельзя\n";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота