В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу на паскале
Дано неотрицательное целое N. Найти сумму и количество цифр в
системе счисления с основанием q.
q=2

Показать ответ
Ответ:
devochka0001
devochka0001
27.12.2020 06:45

var

 i, p, n, q, sum: integer;

 a : array[1..1000000] of byte;

begin

 Write('Введите число N: ');

 ReadLn(n);

 Write('Введите основание системы счисления q: ');

 ReadLn(q);

 p := n;

 while p > 0 do

   begin

     i := i + 1;

     a[i] := p mod q;

     sum := sum + a[i];

     p := p div q;

   end;

 Write(n,'(10) = ');

 for p := i downto 1 do

   Write(a[p]);

 WriteLn('(', q, ')');

 WriteLn('Сумма цифр полученного числа равна ', sum);

 WriteLn('Количество цифр полученного числа равна ', i);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота