В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
РАДЖАБ555
РАДЖАБ555
12.11.2020 21:49 •  Информатика

Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы

Показать ответ
Ответ:
Kira3998
Kira3998
07.10.2020 01:42
Для Одри можно и покороче ))
Только для случая одного корня печатается 2 одинаковых. Так тоже можно

Var a,b,c,d: real;
Begin
WriteLn('Решение ax^2 + bx +c = 0');
WriteLn('Введите a b с '); ReadLn (a, b, c);
if a=0 then WriteLn('Это не квадратное уравнение. Решайте его сами! ')
else
begin
d:=b*b-4*a*c;
if d<0 then Writeln('Нет действительных корней')
else WriteLn('корни: ', (-b+Sqrt(d))/(2*a),' и ', (-b-Sqrt(d))/(2*a) );
end;
ReadLn
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота