В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
marullens
marullens
04.10.2022 09:06 •  Информатика

Напишите программу на паскале, которая выводит все простые числа в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 ), оканчивающиеся на цифру 3. примеры входные данные 2 30 выходные данные 3 13 23

Показать ответ
Ответ:
милания5
милания5
03.10.2020 22:45
Var
 k,n,x,d: integer;

begin
 read(k,n);
 for x := k to n do
  if x mod 10 = 3 then
    begin
    d := 2;
    while x mod d <> 0 do d := d + 1;
    if x = d then write(x,' ');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота