В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
AmAss
AmAss
18.09.2020 09:42 •  Информатика

Напишите программу на паскале определения суммы цифр числа. укажите является ли полученный результат четным числом.

Показать ответ
Ответ:
qvr3k
qvr3k
28.05.2020 08:50

var

  a, c : integer;

begin

  read (a);

  c := 0;

  while a > 0 do

  begin

    c := c + a mod 10;

    a := a div 10;

  end;

  writeln (c);

  if c mod 2 = 0 then write ('Четное') else write ('Нечетное');

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота