В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
даша3635
даша3635
20.06.2020 22:05 •  Информатика

Напишите программу на паскале (pascal abc.net), которая выводит n (число вводится) рандомных строк из файла на экран.

Показать ответ
Ответ:
lazmax2000
lazmax2000
01.08.2021 02:21
var P,i,kc,kn:integer;

Объявляем переменные P,i,kc,kn как целочисленный тип.

begin

Начало программы.

write('P='); //вводим целое число

Выводим на экран "P=".

readln(P);

Считываем переменную P с клавиатуры и переходим на новую строчку.

kc:=0; //четные делители

Присваиваем переменной kc, в которой будет храниться количество четных делителей, значение 0.

kn:=0; //нечетные делители

Присваиваем переменной kn, в которой будет храниться количество нечетных делителей, значение 0.

for i:=2 to P do //от 2 до P

Объявляем цикл с переменной i от 2 до P (до числа, которое мы ввели с клавиатуры).

if P mod i=0 then //если n делится на i, это делитель if odd(i)then inc(kn) else inc(kc); //нечетный или четный

Если остаток от деления P на i равен нулю, то есть P делится на i без остатка, то смотрим: если i нечетная, то увеличиваем kn на 1, иначе (то есть если i четная), увеличиваем kc на 1.

writeln('Количество четных делителей=',kc,' нечетных=',kn)

Выводим на экран:  "Количество четных делителей=",    значение переменной kc,     " нечетных=",      значение переменной kn".

end.

Конец программы.

0,0(0 оценок)
Ответ:
sofyaoborina12
sofyaoborina12
01.08.2021 02:21
var P,i,kc,kn:integer;

Объявляем переменные P,i,kc,kn как целочисленный тип.

begin

Начало программы.

write('P='); //вводим целое число

Выводим на экран "P=".

readln(P);

Считываем переменную P с клавиатуры и переходим на новую строчку.

kc:=0; //четные делители

Присваиваем переменной kc, в которой будет храниться количество четных делителей, значение 0.

kn:=0; //нечетные делители

Присваиваем переменной kn, в которой будет храниться количество нечетных делителей, значение 0.

for i:=2 to P do //от 2 до P

Объявляем цикл с переменной i от 2 до P (до числа, которое мы ввели с клавиатуры).

if P mod i=0 then //если n делится на i, это делитель if odd(i)then inc(kn) else inc(kc); //нечетный или четный

Если остаток от деления P на i равен нулю, то есть P делится на i без остатка, то смотрим: если i нечетная, то увеличиваем kn на 1, иначе (то есть если i четная), увеличиваем kc на 1.

writeln('Количество четных делителей=',kc,' нечетных=',kn)

Выводим на экран:  "Количество четных делителей=",    значение переменной kc,     " нечетных=",      значение переменной kn".

end.

Конец программы.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота