В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
шахзода16
шахзода16
30.11.2022 03:30 •  Информатика

Напишите программу на языке Паскаль. Найдите значение K (значения переменных , Z задаете самостоятельно).
x — Z
К=
, если х>Z;
х+z, если x<=Z.

Показать ответ
Ответ:
Ibrolya
Ibrolya
08.03.2023 00:24

i'm going to read a lot of books this year. я собираюсь прочесть много книг в этом году.

we hope you will solve all your problems soon. мы надеемся, что вскоре ты решишь все свои проблемы.

when everyone took their places my grandmother said "well, now listen to stories". когда все заняли свои места, моя бабушка сказала: "ну, теперь послушайте ".

i will try to answer all your questions. я постараюсь ответить на все твои вопросы.

we're going to discuss this buisness plan with our partners. мы собираемся обсудить этот бизнес-план с нашими партнёрами.

 

0,0(0 оценок)
Ответ:
vaniafatyanov
vaniafatyanov
05.12.2022 12:36
{-}
const
ch_1: array[1..19] of string = ('один', 'два', 'три', 'четыре', 'пять', 'шесть','семь', 'восемь', 'девять', 'десять', 'одиннадцать', 'двенадцать', 'тринадцать','четырнадцать', 'пятнадцать', 'шестнадцать', 'семнадцать', 'восемнадцать', 'девятнадцать');

ch_2: array [2..9] of string = ('двадцать', 'тридцать', 'сорок', 'пятьдесят', 'шестьдесят', 'семьдесят', 'восемьдесят', 'девяносто'); 

ch_3: array [1..9] of string = ('сто', 'двести', 'триста', 'четыреста', 'пятьсот', 'шестьсот', 'семьсот', 'восемьсот', 'девятьсот'); 

var
n : 0..1000;
begin
repeat
write ('Введите натуральное число, меньшее 1000: ');
readln (n);
until n in [1..999];

if n in [100..999] then write (ch_3[n div 100], ' ');
     if (n mod 100) in [20..99] then 
     begin 
         write (ch_2[(n mod 100)div 10], ' '); 
         if (n mod 10) <> 0 then write (ch_1[n mod 10]); 
     end 
     else 
     if (n mod 100) <>0 then write (ch_1[n mod 100]); 

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота