В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lizasergeeva001
lizasergeeva001
13.04.2023 07:22 •  Информатика

Напишите программу (паскаль): выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке. например : 1.информатика 2. 3. 4.физкультура 5. вывод: 1.информатика 5. 3. 4.физкультура 2.

Показать ответ
Ответ:
bika20679
bika20679
23.06.2020 17:30
Uses crt;
const n=5;
var    
s:array[1..n] of string; 
  i,j,c:integer; 
  ss:string;
begin
writeln('Введите :');
for i:=1 to n do begin 
 write('s[',i,']='); 
 readln(s[i]);                       
 end;
for i:=1 to n-1 do
for j:=i+1 to n do
if s[i]>s[j] then 
begin 
 ss:=s[i]; 
 s[i]:=s[j]; 
 s[j]:=ss; 
end;
 for i:=1 to n do
writeln(i,'.',s[i],'  ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота