В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
denzozp08hc1
denzozp08hc1
09.09.2021 21:39 •  Информатика

Напишите программу, по которой будут отбираться все элементы массива В, удовлетворяющие следующему условию: элемент должен быть четным и кратен

Показать ответ
Ответ:
Титова2017
Титова2017
04.12.2020 19:17
Const n=20;
var a:array[1..n]of integer;
i,b,k,c,f,g,h:integer;
begin
for i:=1 to n do a[i]:=Random(70)-20;
for i:=1 to n do
write(a[i],' ');
writeln;
for i:=1 to n do begin
if (a[i] mod 5 = 0) and (a[i] mod 10<>0) or (a[i]=50) then begin
b:=i;
for b:=i to (n-1) do
a[i]:=a[i+1];
end; end;
for i:=1 to n do
write(a[i],' ');
write('введите к ');
read(k);
for i:=1 to n do begin
if a[i] mod i = 0 then begin
c:=i;
for i:=n downto c+1 do begin
a[i]:=a[i-1];
a[c+1]:=k;
end;end;end;
for i:=1 to n do
write(a[i],' ');
writeln;
f:=0; g:=0;
for i:=n downto 1 do begin
if (a[i]>0) then f:=i;
end;
if a[f]=0 then write('нет положительных ');
for i:=n downto 1 do begin
if (a[i]<0) then g:=i;
end;
if (a[g]=0) then write('нет отрицательных ');
if (a[f]<>0) and (a[g]<>0) then begin
h:=a[f]; a[f]:=a[g]; a[g]:=h; end;
for i:=1 to n do
write(a[i],' ');
writeln;
end.
0,0(0 оценок)
Ответ:
TheSiDo
TheSiDo
18.10.2020 17:43

Максимальная цифра м.б. 9, значит сумма цифр не может быть больше 18

1) Сначала уберем из списка все возрастающие - 1619  316   916

   останется 1616  169   163  1916   116

2) Из этого списка удалим также 1916, т.к 19 не может быть (сумма цифр макс 18)

Останется 1616   169   163   116

3) Рассмотрим, все ли числа могли получится, как результат сложения

 1616 могло получится, если число, например, 888. Значит его оставляем

 169   -  например, 972 или 881. Значит, тоже подходит

 163 - 16 может получиться как сумма 8+8  7+9, но тогда мы не получим 3.       Т.е. это число не подходит - удаляем

  116 - это, например, 560, 651, т.е подходит

Значит осталось 1616, 169,  116

ответ: 3

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота