Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
кам81
01.05.2022 00:43 •
Информатика
Напишите программу поиска всех двузначных чисел, в которых есть цифра n или само число делится на n.
Показать ответ
Ответ:
07072002kl
26.06.2020 10:16
Uses crt;
var a,n:integer;
begin
write('n:'); readln(n);
if n>=10 then writeln('error')
else
for a:=10 to 99 do
if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln(a);
end.
0,0
(0 оценок)
Ответ:
diasline
26.06.2020 10:16
Dim i As Integer
Dim msg As String
Dim n As Integer
n = CInt(InputBox("Введите n"))
For i = 10 To 99
If CStr(i).IndexOf(n) > -1 Or i Mod n = 0 Then
msg = msg & i & vbCrLf
End If
Next
MsgBox(msg)
0,0
(0 оценок)
Популярные вопросы: Информатика
m20m
18.01.2021 02:45
Дан прямоугольник с размерами 425х131. от него отрезают квадраты со стороной 131, пока это возможно. затем от оставшегося прямоугольника вновь отрезают квадраты со стороной,...
марго419
25.07.2021 04:39
Y=x2 – 2x- 3 на отрезке [-3,5; 3,5] с шагом 0,5....
ванек1838305958595
16.04.2023 20:22
Предметная область: Гостиница. - Определите сущности. Для каждой сущности выделите атрибуты, первичные и/или внешние ключи. - Постройте ER-диаграмму для заданной предметной...
vkunney
04.07.2020 13:58
парни даны два участка кода, необходимые двум потокам в одном приложении. предложить варианты их синхронизации...
769429
14.12.2022 14:14
Составить программу для вывода на экран сообщения « вы еще долго проживете» если пользователь ввел свой возраст меньше 40 лет и «вы неплохо сохранились» если наоборот. Логику...
sergazinaaidana
16.08.2021 17:31
1. как называется класс, который на примере ниже? type tform1 = class(tform) memo1: tmemo; button1: tbutton; procedure button1click(sender: tobject); . . end; 2. что обозначает...
CailiVinchisiter
22.02.2020 23:36
Написать программу на языке pascal. 1: вводится название месяца. вывести пору года для этого месяца (январь - зима, …, март - весна, …, август - лето, …); 2: вводиться пора...
star1010
22.02.2020 23:36
4-61 5-52 6-63 7-94 8-46 9-? какое число надо поставить вместо знака вопрос....
2005282
09.10.2021 19:37
Найдите значение выражения (5c-6)(5c+-6)в квадрате...
vitashe135
09.10.2021 19:37
Что из перечисленного стало причиной крещения руси? 1) стремление закрепить внутреннее единство государства 2) необходимость установить дипломатические отношения с волжской...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a,n:integer;
begin
write('n:'); readln(n);
if n>=10 then writeln('error')
else
for a:=10 to 99 do
if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln(a);
end.
Dim msg As String
Dim n As Integer
n = CInt(InputBox("Введите n"))
For i = 10 To 99
If CStr(i).IndexOf(n) > -1 Or i Mod n = 0 Then
msg = msg & i & vbCrLf
End If
Next
MsgBox(msg)