В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nаstуа23
Nаstуа23
02.08.2021 22:16 •  Информатика

Напишите программу получения из элементов матрицы трёх списков.Первый состоит из чисел , больших введенного значения , второй - из элементов, меньших этого числа, третий - из элементов , равных чисел на питоне

Показать ответ
Ответ:
жазира22
жазира22
31.10.2021 07:40

matrix = ...    # тут должна быть матрица

value = int(input('Введите значение: '))

a = []

b = []

c = []

for row in matrix:

   for element in row:

       if element > value:

           a.append(element)

       elif element < value:

           b.append(element)

       else:

           c.append(element)

print(a)

print(b)

print(c)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота