В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Danyaizbanu
Danyaizbanu
12.09.2022 19:56 •  Информатика

Напишите программу увеличивающую каждый элемент матрицы (n,m) в 3 раза и сохраняющую результат в виде второй матрицы

Показать ответ
Ответ:
katyanosa
katyanosa
02.10.2020 04:34
Uses  
CRT;
Const  
nmax=40;  
mmax=40;
var  a,b:array[1..nmax,1..mmax] of integer;  
i,j,n,m:integer;
begin
ClrScr;
repeat  
write('N:=');  
Readln(n);
until n in [1..nmax];
repeat  
write('M:=');  
Readln(m);
until m in [1..mmax];
writeln('Исходный массив: ');
randomize;
for i:=1 to n do
begin  
for j:=1 to m do  begin  
a[i,j]:=random(10)-3;  
write(a[i,j]:5);  
b[i,j]:=a[i,j]*a[i,j]*a[i,j];  
end;
writeln;
end;
writeln('Результирующий массив: ');
for i:=1 to n do
begin  
for j:=1 to m do  
begin  
write(b[i,j]:5);  
end;
writeln;
end;
readkey
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота