В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
temalishchenko
temalishchenko
03.07.2021 23:03 •  Информатика

Напишите программу, в которой бы в теле функций производились вычисления со значениями трёх переменных

Показать ответ
Ответ:
Nikiton101
Nikiton101
06.02.2020 05:43
#include "math.h"
#include <iostream>
using namespace std;
int main()
{
//объявление переменных
float xa, ya, xb, yb, ab ;
//ввод переменных 
cout<<"Vvedite xa: "<<endl;
cin>>xa;
cout<<"Vvedite ya: "<<endl;
cin>>ya;
cout<<"Vvedite xb: "<<endl;
cin>>xb;
cout<<"Vvedite yb: "<<endl;
cin>>yb;
//расчет длинны отрезка
ab=sqrt(pow(xa-xb,2)+pow(ya-yb,2);
//вывод длины отрезка
cout<<"|AB| = "<<ab<<endl;
system("pause");
return 0;
}
0,0(0 оценок)
Ответ:
ms71431
ms71431
06.02.2020 05:43

Fasm

 

org 100h

mov si, string
cld

my_loop:
lodsb
cmp al, 0
jz loop_exit
cmp al, '0'
jb my_loop
cmp al, '9'
ja my_loop
sub al, '0'
add bx, ax
jmp my_loop

loop_exit:
push -1
mov ax, bx
loop_push:
xor dx, dx
div [d]
push dx
cmp ax, 0
jne loop_push
mov ah, 2h

print:
pop dx
cmp dx, -1
je exit
add dl, '0'
int 21h
jmp print

exit:
mov ah, 01h
int 21h
ret


d dw 10
string db "1", 0

 

FPC

 

var
s : string;
i, c : integer;
begin
readln (s);
c := 0;
for i := 1 to length (s) do
if (s[i] in ['0'..'9']) then inc (c, ord (s[i]) - ord ('0'));
writeln (c);
end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота