Напишите программу, в которой определяются координаты точки С (x,y), делящей отрезок AB
с координатами концов А(x1,y1) и В(x2,y2) на части таким образом, что AC=m*АВ (где 0 От пользователя требуется ввод координат точек А и В и коэффициента m. Решить на паскале
#include <iostream>
using namespace std;
int main()
{
int x;
cout << "Введите значение X: ";
cin >> x;
if (x >= -4 && x <= 1)
{
cout << "1";
}
else
{
cout << "0";
}
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
using namespace std; // Пространство имён
int main()
{
int x; // Создание целочисленной переменной x
cout << "Введите значение X: "; // Вывод сообщения в консоль
cin >> x; // Вводим значение с клавиатуры
if (x >= -4 && x <= 1) // Если значение переменной x ≥ -4 И ≤ 1
{
cout << "1"; // Выводим 1
}
else // Иначе
{
cout << "0"; // Выводим 0
}
}
//PascalABC
var
S : array[1..10000] of integer;
A, B, C, i, N, min : integer;
W : real;
begin
write('Укажите размер массива > ');
readln(N);
write('Вводите элементы массива > ');
for i := 1 to N do
readln(S[i]);
A := 0;
min := S[1];
C := 0;
for i := 1 to N do begin
if S[i] > 0 then A := A + S[i];
if S[i] < min then begin
B := i;
min := S[i];
end;
if S[i] mod 5 = 0 then C := C + 1;
end;
W := B + A / (C + 1);
writeln('Сумма элементов ', A);
writeln('Номер минимального эл-та ', B);
writeln('Количество кратных пяти ', C);
writeln('Параметр W ', W);
end.