В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Золушка251
Золушка251
05.04.2020 22:20 •  Информатика

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat

Показать ответ
Ответ:
Makspoerty
Makspoerty
13.10.2020 12:04

var a,s: integer;

begin

s:=1;

repeat

write('Введите число: ');

readln(a);

if (a>0) then s:=s*a;

until a=1;

writeln('Произведение положительных чисел: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота