Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
hellppp1
08.03.2021 08:03 •
Информатика
Напишите программу в pascal дано трехзначное число х. если х-четное число, то вычислить сумму цифр этого числа. если х-нечетное, то вычислить число-перевертыш
Показать ответ
Ответ:
Bsusb
08.10.2020 19:29
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.
Примеры
n= 531
135
n= 428
14
0,0
(0 оценок)
Популярные вопросы: Информатика
yoooyooo
28.11.2021 02:39
Очень Запиши число в десятичной системе счисления. 8BC 16 2. Определи основание системы счисления числа 226 10 3. Переведи число в десятичную систему счисления 2022 8 4. Выполни...
Bollsav
03.06.2022 09:09
Дан одномерный массив. Запиши верный ответ. −18 22 0 −3 1 12 Значение элемента массива — 12. Индекс элемента массива —...
mariya1810
06.11.2022 15:15
Выполнить практическую работу Настройка эффектов анимации и гиперссылок к объектам слайдов...
ultraomegaus
19.11.2022 16:55
Здравствуйте мне почему такое искажение и как исправить?...
mot3333
18.04.2020 11:13
Каково наибольшее целое число X, при котором ложно высказывание: (х*(х+1) 55)→(х*х 50)?...
лена6ада
08.04.2021 22:12
Два текста содержат одинаковое количество символов первый текст составлен из символов алфавита мощностью 256 символов второй мощностью 32 символа во сколько раз различаютчя информационные...
twicгр66
07.11.2020 22:33
Составить программу, которая находит среднее арифметическое элементов непустого однонаправленного списка вещественных чисел, заменяет все вхождения числа x на число y, меняет...
SofiaSendekaeva
02.08.2022 06:16
Решите Расставьте результаты этапов решения задачи с использованием компьютера в правильной последовательности (от первого к последнему): 1 Программа 2 Уточнённая модель 3 Результат...
flimas
29.09.2021 04:29
Склавиатуры вводится n чисел. найти сумму чисел умноженных на 2 (паскаль)...
dbjshsg
19.09.2021 07:21
Составить программу ,которая запрашивает год начала великой отечественной войны и анализирует введенное число(верно или неверно)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.
Примеры
n= 531
135
n= 428
14