В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Hellybery
Hellybery
05.05.2023 00:13 •  Информатика

Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.

Показать ответ
Ответ:
Uliana7003
Uliana7003
11.10.2020 02:34

Объяснение:

Var s,n:integer;

Begin

   write('Введите число: ');readln(n);

   s:=0;

   While n<>0 do

    Begin

     if n mod 10 mod 2 = 0 then s:=s+n mod 10;

     n:=n div 10;

    End;

   if s<>0 then writeln('Сумма четных цифр: ',s)

    else writeln('Нету четных цифр в числе');

   readln;

End.

Может быть неправильной.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота