В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
CHeryPk
CHeryPk
12.01.2021 15:01 •  Информатика

Напишите программу в паскаль находящую у при условиях. у=х2, если х> 0, у=5, если х=10, у=х2, если х< 10

Показать ответ
Ответ:
sinocek1
sinocek1
03.07.2021 12:32

Описание алгоритма:

Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):

1) Заканчиваются на 0.

2) Ровно на одну единицу

3) Ровно на две единицы.

Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для a=1 и b=2 также работает правильно.

Программа на Pascal:

var num00,num01,num11,mem00:integer;

   a,i:byte;

begin

readln(b);

 num00:=1;

 for i:=1 to n do begin

   mem00:=num11;

   num11:=num01;

   num01:=num00;

   num00:=num01+num11+mem00;

 end;

writeln(num11+num01+num00);

end.

Объяснение:

извени если ошебусь

:)

0,0(0 оценок)
Ответ:
alinaetosila2004
alinaetosila2004
21.08.2020 13:15

Ilpnauenne 1 ot;ТЕКАННЕ РИСУНКА ТЕкстом MICROSOFT WORD - omm nanóanee ponpo- станні пістои редактор, соданнill фир Mofi Afierosoft Corp, mpornimnMa, KOTopar noOnser баріат, паплыть, форматировать и растент нати текст. В окно также проператорфо тарто, пунктуашно, стил, текст, хот доверить олностью и прессы программе не pekOMerivercR Тексты ростаглі мога фармаар мангут быть импор пированы и других программ настроены тест доку непотуются на еление рисунки, комліла армат аъекта дитиніруется калпа акепс, принт і рам РАСПОЛОЖЕНИЕ РУкл под ТЕкстом TERROR peEpo, cnt upon Aternos Corp pe pan, satopa nihne ert cip , popnponas тиетом и анклуза с пылете, далее абарабъекти, стер ашия орна апр арилгусу Ама текста отнасосы рисунка, ГАЗЕтный стиль ТЕКСТА тип форматиро- AT ТЕКСТ Opop- MHM TEKCT O seT- ном стиле е бук- eroro cruit it nenemoro dpar- Meta Teata - сте с последовательно 39 en NOMA Pa yerananHmoTCH параметры Bapitais т газетного тек ста. Для оформле GyKHt MC- пользуют команду Нетанка, Букин MICROSOFT FORD 113 иболее распро сто релла- pon conanali pupuoll Alicrenoft Corp программа, набирать, испраць-

Вот что удалось скопировать

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота