напишите программу в паскале: Дан целочисленный массив из n элементов, все элементы которого – целые числа. Найти среднее арифметическое всех положительных элементов массива, которые кратны первому элементу.
Во всех заданиях надо работать со степенями двойки. 1. Шанс вытащить какой-то конкретный шар составляет 1 из 32. Следовательно, информация о вытащенном шаре уменьшает неопределенность в 32 раза. Есть формула Хартли, которая говорит, что объем информации в битах будет численно равен логарифму по основанию два от величины уменьшения неопределенности. Но в некоторых случаях можно воспользоваться тем, что если число является степенью двойки, то значение логарифма будет являться этой степенью. У нас 32 - это два в пятой степени, поэтому значение логарифма равно 5. ответ: Сообщение содержит 5 бит информации. 2. Выбор одного из 8 карандашей снижает неопределенность в 8 раз, восемь - это два в кубе, следовательно логарифм равен 3. ответ: Сообщение содержит 3 бита информации. 3. Если было получено 6 бит информации, то делаем обратную операцию - возводим двойку в эту шестую степень. Получаем 64. ответ: диапазон содержит 64 числа (от 0 до 63). 4. 16 стеллажей и в каждом 8 полок. Всего 16x8=256 полок. Координаты книги - 1 из 256 возможных вариантов. 256 - это два в восьмой. ответ: Сообщение содержит 8 бит информации. 5. В книге 512 страниц, закладка может лежать на любом из 512 мест. 512 - это два в девятой степени. Значит, сообщение о месте закладки несет информацию в 9 бит. ответ: Сообщение несет 9 бит информации.
1. Шанс вытащить какой-то конкретный шар составляет 1 из 32. Следовательно, информация о вытащенном шаре уменьшает неопределенность в 32 раза. Есть формула Хартли, которая говорит, что объем информации в битах будет численно равен логарифму по основанию два от величины уменьшения неопределенности. Но в некоторых случаях можно воспользоваться тем, что если число является степенью двойки, то значение логарифма будет являться этой степенью. У нас 32 - это два в пятой степени, поэтому значение логарифма равно 5.
ответ: Сообщение содержит 5 бит информации.
2. Выбор одного из 8 карандашей снижает неопределенность в 8 раз, восемь - это два в кубе, следовательно логарифм равен 3.
ответ: Сообщение содержит 3 бита информации.
3. Если было получено 6 бит информации, то делаем обратную операцию - возводим двойку в эту шестую степень. Получаем 64.
ответ: диапазон содержит 64 числа (от 0 до 63).
4. 16 стеллажей и в каждом 8 полок. Всего 16x8=256 полок. Координаты книги - 1 из 256 возможных вариантов. 256 - это два в восьмой.
ответ: Сообщение содержит 8 бит информации.
5. В книге 512 страниц, закладка может лежать на любом из 512 мест. 512 - это два в девятой степени. Значит, сообщение о месте закладки несет информацию в 9 бит.
ответ: Сообщение несет 9 бит информации.
n = 10;
var
a: array[0..10] of integer;
i, s: integer;
begin
//Заполнение массива сл. числами
for i := 1 to n do
begin
a[i] := random(201) - 100;
write(a[i]:4);
end;
writeln;
//1) Все элементы не превышающие число 100
writeln('Не больше 100 ');
for i := 1 to n do
if a[i] <= 100 then
write( a[i]:4);
writeln;
// 2) Все четные элементы
writeln('Кратные двум ');
for i := 1 to n do
if a[i] mod 2 = 0 then
write( a[i]:4);
writeln;
// 3) Все элементы, являющиеся трехзначными числами
writeln('Трехзначные ');
for i := 1 to n do
if (a[i] < -99) or (a[i] > 99) then
write(a[i]:4);
writeln;
// 4) Третий, шестой и т.д элементы.
i := 3;
writeln(' номера 3, 6, 9 и т.д.');
while i < n do
begin
write(a[i]:4);
i := i + 3;
end;
end.