В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
карина5647
карина5647
02.03.2020 16:39 •  Информатика

Напишите программу «Визитная карточка», которая выводила бы на экран хорошо оформленные ваши личные данные: имя, фамилию, год рождения, адрес, телефон. Используйте разные цвета, хорошо скомпонуйте. С использованием модуля (CRT)

Показать ответ
Ответ:
olgaborodec82
olgaborodec82
28.07.2021 21:32

 

type Man = record

        name: String;

        surname: String;

        date: record

            day: Integer;

            month: Integer;

            year: Integer;

        end;

    end;

 

var people: Array [1..100] of Man;

   i,n,_year: Integer;

   _name: String;

 

begin

   Write('Enter number of man: ');

   ReadLn(n);

   for i := 1 to n do

   With people[i] do

   begin

       WriteLn('Man[',i,']:');

       Write('Enter name: ');

       ReadLn(name);

       Write('Enter surname: ');

       ReadLn(surname);

       Write('Enter birthday Day/Month/Year: ');

       ReadLn(date.day, date.month, date.year);

       WriteLn;

   end;

   Write('Enter year: ');

   ReadLn(_year);

   for i := 1 to n do

   With people[i] do

       if (date.year = _year) then

           WriteLn('Name: ',name,' Surname: ',surname);

   WriteLn;

   Write('Enter name: ');

   ReadLn(_name);

   for i := 1 to n do

   With people[i] do

       if (name = _name) then

       begin

           Write(surname,' ',name);

           WriteLn(' ',date.day,'.',date.month,'.',date.year);

       end;

   ReadLn;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота