В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
stasvikulyа
stasvikulyа
02.06.2020 05:23 •  Информатика

Напишите программу вычисления наименьшего общего кратного в следующих четырех чисел : 36,54,18 и 15 . используйте процедуру вычисления наибольшего общего делителя двух чисел.

Показать ответ
Ответ:
Холбол
Холбол
07.10.2020 17:25
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function HOK(a,b:integer):integer;
begin
  Result:=a*b;
  while b>0 do (a,b):=(b,a mod b); // a - НОД
  Result:=Result div a
end;

begin
  Writeln('НОК(36,54,18,15)=',HOK(HOK(36,54),HOK(18,15)))
end.

Результат
НОК(36,54,18,15)=540
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота