В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kalishevij99
kalishevij99
21.03.2023 07:51 •  Информатика

Напишите программу вычисления произведения ненулевых эл. массива. Проверьте работу программы {7, 25, 4.5, 0, 17, 61, - 10, 0, 1, - 4, 22}.
Произведения ненулевых эл равно:...

Показать ответ
Ответ:
Натаван11082004
Натаван11082004
14.10.2020 03:48

using System;

using System.Collections.Generic;

using System.Linq;

namespace Prog

{

   class Program

   {

       static void Main(string[] args)

       {

           List<double> array = new List<double>() { 7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22 };

           // TASK 5

           int positive, negative, zero;

           var tmp = array.FindAll(x => x > 0);

           positive = tmp.Count;

           tmp = array.FindAll(x => x == 0);

           zero = tmp.Count;

           negative = array.Count - zero - positive;

           Console.WriteLine($"Кол-во полож. элементов: {positive}\n\rКол-во нулевых элементов: {zero}\n\rКол-во отриц. элементов: {negative}");

           // TASK 6  

           double prv = 1;

           for (int i = 0; i < array.Count; ++i)

           {

               if (array[i] != 0)

               {

                   prv *= array[i];

               }

           }

           Console.WriteLine($"Произведение ненулевых элементов равно: {prv}");

           Console.ReadKey();

       }

   }

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота