В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
1993nnnn
1993nnnn
08.01.2020 21:09 •  Информатика

Напишите программу: вычислить сумму и количество элементов, находящихся в интервале [a,b] для массива а[n]. (pascal, 8 класс)

Показать ответ
Ответ:
zhenya214
zhenya214
08.04.2022 21:54

В новой операционной системе Microsoft улучшила возможности проигрывания контента и управлении им в Windows Media Player 12. Речь идет не только о переработке дизайна проигрывателя, но и о работе с ним ключевых преимущественных возможностей Windows 7, вроде новой панели задач, домашних групп HomeGroup и списков Jump Lists.

В своем блоге компания даже написала шесть статей, посвященных новому проигрывателю, в первой из которых было рассказано о том, какие комбинации клавиш можно использовать при работе с Windows Media Player 12 под Windows 7. Ниже представлена таблица комбинаций клавиш, которые вы можете использовать для выполнения различных действий в проигрывателе Windows Media Player 12, начиная от перехода в режим плеера Player Mode и заканчивая включением или выключением режима случайного выбора shuffle mode.

И если вы любите использовать клавиатуру, то вам просто необходимо иметь эту таблицу.

Комбинация клавиш

Действие

Состояние

Ctrl + 1 Переключиться в режим библиотеки Из любого режима

Ctrl + 2 Переключиться в режим скина Из любого режима

Ctrl + 3 Переключиться в режим плеера Из любого режима, исключая полноэкранный

Ctrl + 7 Добавить в список проигрывания В режиме библиотеки

Ctrl + 8 Добавить в список записи В режиме библиотеки

Ctrl + 9 Добавить в список синхронизации В режиме библиотеки

Ctrl + A Выбрать все элементы в списке В библиотеке или списке

Ctrl + B Предыдущий (элемент или раздел) При проигрывании контента

Ctrl + E Сфокусироваться на поиске и перейти в режим библиотеки, если еще не в нем

Ctrl + F Следующий (элемент или раздел) При проигрывании контента

Ctrl + H Включить/выключить режим случайного выбора shuffle mode

Ctrl + J Извлечь В любом режиме

Ctrl + M Переключить меню в библиотеке В любом режиме

Ctrl + N Создать плейлист (список проигрывания) В режиме библиотеки

Ctrl + O Показать диалог открытия В любом режиме

Ctrl + P Переключатель проигрывания / паузы Контента в очереди

Ctrl + Q Добавить выбранный трэк в открытый список По умолчанию в списке проигрывания

Ctrl + S Остановить проигрывание Проигрываемого контента

Ctrl + T Включить / выключить режим повтора В любом режиме

Ctrl + U Показать диалог открытия ссылки URL В любом режиме

Ctrl + W Остановить проигрывание При проигрывании контента или на паузе

Ctrl + Shift + B Перемотка проигрываемого контента назад При проигрывании DVD

Ctrl + Shift + C Включение / выключение субтитров Для контента с субтитрами

Ctrl + Shift + F Ускорить проигрывание контента При проигрывании контента

Ctrl + Shift + G Скорость проигрывания быстрая При проигрывании контента

Ctrl + Shift + N Скорость проигрывания нормальная При проигрывании контента

Ctrl + Shift + S Скорость проигрывания медленная При проигрывании контента

Ctrl + Стрелка вправо Следующий плейлист (список проигрывания) в истории списков При фокусе не на панели перемотки

Ctrl + Стрелка влево Предыдущий плейлист (список проигрывания) в истории списков При фокусе не на панели перемотки

Ctrl + Стрелка вправо Отмотать вперед (на много) При фокусе на панели перемотки (бегунке)

Ctrl + Стрелка влево Отмотать назад (на много) При фокусе на панели перемотки (бегунке)

Стрелка вправо Отмотать вперед (на немного) При фокусе на панели перемотки (бегунке)

Стрелка влево Отмотать назад (на немного) При фокусе на панели перемотки (бегунке)

Ctrl + клик Подогнать размер плеера под изображение В режиме проигрывается сейчас

Escape Вернуться в режим сейчас проигрывается В полноэкранном режиме

F1 Открыть файл В любом режиме

F2 Редактировать мета-данные В режиме библиотеки с выбранным элементом

F4 Переключить режим просмотра В режиме библиотеки с фокусом на просмотре списка

F5 Обновить экран При фокусе на библиотеке или на онлайновом сервисе

F6 Увеличить рисунок альбома При фокусе на просмотре списка

Shift + F6 Уменьшить рисунок альбома При фокусе на просмотре списка

F7 Отключить звук В любом режиме

F8 Уменьшить громкость звука В любом режиме

F9 Увеличить громкость звука В любом режиме

F10 Показать панель меню в библиотеке Из любого режима

Shift + F10 Контекст ярлыка меню В любом режиме

Alt + 1 Размер видео 50% В режиме проигрывается сейчас или скина при проигрывании видео

Alt + 2 Размер видео 100% В режиме проигрывается сейчас или скина при проигрывании видео

Alt + 3 Размер видео 200% В режиме проигрывается сейчас или скина при проигрывании видео

Alt + Enter Переключатель полноэкранного режима В режиме проигрывается сейчас, скина или в полноэкранном режиме

Объяснение:

интернет.

0,0(0 оценок)
Ответ:
McShram1111
McShram1111
08.01.2022 15:09

begin

 var N: array of integer;

 SetLength(N,16);

 N.FillRandom(1,11);

 var Q:=N.FindAll(x -> x mod 2 = 0).Length;

 writeln('Количество четных элементов:',Q);

 N.Sort; Reverse(N);

 for var l:=N.Low to N.High do N[l]:=(N[l] mod 2 = 0)? Q:N[l];

 writeln('Полученный массив: ',N);

end.

Объяснение:

var N: array of integer; Вводим наш массив с числами

 SetLength(N,16); Устанавливаем его длину, 0 - первый элемент, 15 - последний, итого 16 ячеек

 N.FillRandom(1,11); Заполняем массив случайным образом числами от 1 до 11

 var Q:=N.FindAll(x -> x mod 2 = 0).Length; Находим количество четных элементов. x mod 2 остаток от деления каждого элемента на 2

 {Процедура FindAll заносит все значения, по условию в отдельный массив, через .Length смотрим его длину}

writeln('Количество четных элементов:',Q);

 N.Sort; Reverse(N); N.Sort - сортирует массив по возрастанию, а reverse() меняет последовательность на противоположную, соответственно, теперь он отсортирован по убыванию

 for var l:=N.Low to N.High do N[l]:=(N[l] mod 2 = 0)? Q:N[l];  От начала массива и до его конца, над каждым элементом смотрим - четный он или нет, если четный - заменяем на Q (число элементов)

 writeln('Полученный массив: ',N);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота