В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lavrinenkoll
lavrinenkoll
05.06.2023 11:36 •  Информатика

Напишите программу, запрашивающую три стороны треугольника а, в, с и вычисляющую его площадь по формуле герона

Показать ответ
Ответ:
mavlud111
mavlud111
03.07.2020 22:03
Если паскаль, то форму сам знаешь как, наверное вот тебе тело.
var p,S,AB,BC,AC :real(если не работает, то Integer);
begin
readln(AB);
readln(BC);
readln(AC);
p:=(AB+BC+AC)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
Writeln(s)
end.
Поправь там знаки или ещё что-нибудь - я не в программе писал.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота