В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Leerok
Leerok
04.04.2020 17:30 •  Информатика

Напишите программы на паскале, используя цикл "пока". 1)составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. 2)дано целое число х и натуральное n. составьте алгоритм вычисления х^n.

Показать ответ
Ответ:
Logutova
Logutova
07.10.2020 21:33
1)
Program n1;
var sum,n,i: integer;
begin
i:=1;
sum:=0;
readln(n);
while i<=n do
begin
sum:=sum+i;
i:=i+1;
end;
write(sum);
end.

2)
Program n2;
var x,n,i,z: integer;
p: integer;
begin
readln(x,n);
i:=0;
p:=1;
z:=1;
if x<0 then z:=-1;
x:=abs(x);
while i<>n do
begin
p:=p*x;
i:=i+1;
end;
if (z=-1) and (i mod 2=0) then write(p) else if (z=-1) and (i mod 2<>0) then write(-p) else write(p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота