В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
almaz2008
almaz2008
07.04.2023 06:20 •  Информатика

Напишите

составить программу, которая вычисляет и выводит на экран 20% (вывод а) от стоимости покупки с, вводимой с клавиатуры( ввод с)

Показать ответ
Ответ:
renatadautova
renatadautova
03.02.2020 21:48
В СССР доступные бытовые магнитофоны распространились примерно со второй половины 1950-х — начала 1960-х годов. В это время возникло особое социальное явление — магнитофонная культура или «магнитиздат». Легкость копирования магнитных записей позволила почти неограниченно распространять произведения, не одобрявшиеся официальной идеологией, но популярные в народе: песни бардов и первых полуподпольных рок-групп, западную популярную музыку, неофициальные выступления писателей-сатириков, лекции по уфологии, передачи «вражеских голосов» и т. п.[30][31] Магнитофоны быстро вытеснили с рынка кустарную грамзапись — грампластинки, записанные на использованной рентгенопленке («музыка на ребрах»).
0,0(0 оценок)
Ответ:
крыл8888
крыл8888
11.05.2023 08:02
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота