1Найдите значение выражения 8F – 80 в шестнадцатеричной системе счисления. В ответе запишите вычисленное значение в десятичной системе счисления.
Решение.
Переведём число 8F16 из шестнадцатеричной в десятичную систему счисления:
8F16 = 14310.
Переведём число 8016 из шестнадцатеричной в десятичную систему счисления:
8016 = 12810.
Найдём разность: 143 − 128 = 15.
2
Найдите значение выражения 1116 + 118 : 112. ответ запишите в двоичной системе счисления.
Переведем все числа в десятичную систему счисления, выполним действия и переведем результат в двоичную систему счисления:
1116 = 16 + 1 = 1710,
118 = 8 + 1 = 910,
112 = 2 + 1 = 310,
17 + 9 : 3 = 17 + 3 = 2010,
20 = 16 + 4 = 10100 и маленькая два вместе с ответом
3
Вычислите значение выражения B916 − 2718. В ответе запишите вычисленное значение в десятичной системе счисления.
Решение.
Переведём числа в десятичную систему счисления:
B916 = 18510
2718 = 18510
Найдём разность: 185 − 185 = 0.
ответ дай лучшего ответа
1Найдите значение выражения 8F – 80 в шестнадцатеричной системе счисления. В ответе запишите вычисленное значение в десятичной системе счисления.
Решение.
Переведём число 8F16 из шестнадцатеричной в десятичную систему счисления:
8F16 = 14310.
Переведём число 8016 из шестнадцатеричной в десятичную систему счисления:
8016 = 12810.
Найдём разность: 143 − 128 = 15.
2
Найдите значение выражения 1116 + 118 : 112. ответ запишите в двоичной системе счисления.
Решение.
Переведем все числа в десятичную систему счисления, выполним действия и переведем результат в двоичную систему счисления:
1116 = 16 + 1 = 1710,
118 = 8 + 1 = 910,
112 = 2 + 1 = 310,
17 + 9 : 3 = 17 + 3 = 2010,
20 = 16 + 4 = 10100 и маленькая два вместе с ответом
3
Вычислите значение выражения B916 − 2718. В ответе запишите вычисленное значение в десятичной системе счисления.
Решение.
Переведём числа в десятичную систему счисления:
B916 = 18510
2718 = 18510
Найдём разность: 185 − 185 = 0.
ответ дай лучшего ответа
//Console application
#include<iostream>
using namespace std;
struct coords {
double x;
double y;
};
double findLen ( double x, double y, double x1, double y1) {
return sqrt(pow(x1 - x, 2) + pow(y1 - y, 2)); //теорема пифагора ( расстояние между двумя точками )
}
double findS( double firstLen, double secLen, double thirdLen) {
double p = (firstLen + secLen + thirdLen) / 2;
return sqrt(p * (p - firstLen) * (p - secLen) * (p - thirdLen)); //формула Герона
}
int main() {
coords A, B, C;
cout << "Input coords for point A : x = "; cin >> A.x;
cout << "\t\t\t y = "; cin >> A.y;
cout << "Input coords for point B : x = "; cin >> B.x;
cout << "\t\t\t y = "; cin >> B.y;
cout << "Input coords for point C : x = "; cin >> C.x;
cout << "\t\t\t y = "; cin >> C.y;
cout << endl << endl; cout << "S for ABC : "<<findS(findLen(A.x,A.y,B.x,B.y), findLen(B.x, B.y, C.x, C.y), findLen(A.x, A.y, C.x, C.y))<<endl;
system("pause"); //если не компилируется, убери эту строку
return 0;
}