В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Redycter12
Redycter12
05.12.2022 21:10 •  Информатика

найти ошибку! Написать программу на СИ, запрашивающую у пользователя в бесконечном цикле число и выводящую среднее значение всех введённых ранее чисел. Вывод в формате: "Среднее значение этих ... чисел равно ...". Среднее значение выводить с точностью до 5 десятичных знаков (т.е. до 1/100000).

Программа перестаёт работать или при вводе символа вместо числа, или при истечении 1 минуты с момента ввода первого числа.

Или найти ошибку

#include // Библиотека для работы с функциями ввода-вывода

#include // Библиотека для указания локации (региональной кодировки)

#include // Библиотека математических функций

#include // Библиотека для работы с временем

int main() {

setlocale(LC_ALL, "Rus");

time_t start, end;

int timelim = 60;

int a = 0;

int i = 1, s;

float c;

start = time(NULL);

end = time(NULL);

for ( ; difftime(end, start) < timelim; end = time(NULL)) {

for (i = 1; i > 0; i++) {

printf("Введите число:\n");

scanf_s("%d", &s);

a += s

c = a / i;

if (scanf_s("%d", &s) < 1) {

printf("Только числа нужны нам. Ошибку допустил ты...\n");

return 0;

}

printf("Среднее значение этих %d чисел равно %.3f ", i, c);

}

printf("Ваше время истекло...\n");

printf("Пока!\n");

return 0;

}

Показать ответ
Ответ:
kotuk333
kotuk333
02.12.2020 03:26
1) a:=x div 100 (в переменную а присваивается переменная x деленная на 100 без остатка, по другому a= x/100 без остатка, a=125/100= 1.25 b ,и берем только 1, a=1 )
2) b:=x mod 100 div 10 (в переменную b присваивается переменная x деленная на 100 b и берется остаток, а потом число которое получилось делиться на 10 и берется только целая часть,b = 125/100=1,25 берем только 25, 25/10=2,5 берем целую часть то есть 2, b=2 )
3) c:=x mod 10 (в переменную с присваивается переменная x деленная на 10, по другому с= x/10 без остатка, с=125/10= 12,5 b ,и берем только 5, с = 5)
4) s:=a *b*с=1*2*5=10
0,0(0 оценок)
Ответ:
Жебир
Жебир
03.01.2022 15:26
А) не ( A или не В и С ) упрощаем выражение и получаем
not(a) and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=not(a) and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)

б) А и не ( В и или не С) получим такое выражение:
a and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)


в) не ( не А или В и С)  преобразуем:
a and (b or c)

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or c)
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота