Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
anakukla2
15.10.2022 03:14 •
Информатика
Написать программу по информатики для решения : в массиве рост юношей задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек.
Показать ответ
Ответ:
арина1494
05.10.2020 03:51
#include <iostream>
#include <vector>
using namespace std;
int main() {
cout << "Введите массив (0, чтобы закончить):\n";
int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector<int> v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "
<< (sb / cb) << '\n'
<< "Средний рост девушек: "
<< (sg / cg) << '\n';
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Алина678901
11.07.2022 18:04
Составьте блок-схему и программу на бейсике вычисления функции y,где x задаётся с клавиатуры....
Испан1
26.09.2022 19:53
Можете составить алгоритм в виде блок схем. решите . есть 9 монет.одна из них фальшивая , она легче настоящей (все настоящие весят одинаково).как за два взвешивания на...
A1mSh1k
30.09.2021 14:46
Найдите такие значения x,y , чтобы числа x,y и 45 были соответственно пропорциональны числам 2, 5 и 1/9 (Дробь типо)...
алина3893
17.03.2023 17:14
Есе на тему Громада очима дітей через 5 років тре ів)...
1Polina2211
28.09.2020 22:29
Памятка Порядок определения сторон света по компасу, местным признакам....
maloy4424
27.04.2021 18:19
Пальто стоило 2700 р. Сначала его цену снизили на 20%, а потом новую цену повысили на 30%. Какой стала цена пальто после этих изменений? На сколь- ко процентов изменилась...
кобра453
12.07.2020 19:20
1. Назовите детенышей животных, выделите суффиксы в словах: У лягушки- У кошки- У лисы- У гуся- У коня- 2 . Продолжите ряд названий лиц по профессии: учить- учитель, барабанить-...
мария2382
26.06.2021 23:07
Задание 355. Спишите словосочетания, вставляя пропу- щенные буквы. образец: плюшевый (прил.) медвежонок (сущ.). Кованый сундуч..к, слышишь трещ..тку, парч.вая ткань, камыш..вые...
NastyaCat21
16.05.2020 20:15
Узагальнений образ поета романтика...
SkylloutBrain
13.02.2023 02:09
Краткий пересказ параграфа 31 по биологии 7 класс лятюшин...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <vector>
using namespace std;
int main() {
cout << "Введите массив (0, чтобы закончить):\n";
int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector<int> v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "
<< (sb / cb) << '\n'
<< "Средний рост девушек: "
<< (sg / cg) << '\n';
return 0;
}