В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
YIUYA123DANIL
YIUYA123DANIL
03.02.2023 20:50 •  Информатика

Но только решение должно быть не через массив, а через циклы (либо repeat, либо for, либо while). : последовательно вводится n целых чисел. найдите минимальное и максимальное число из введенных чисел.

Показать ответ
Ответ:
Hhjkklknbggfddxxg
Hhjkklknbggfddxxg
08.10.2020 11:17
Var n,i,max,min,a: integer;
begin
write('Введите количество чисел (N): ');
readln(n);
write('Введите число: ');
readln(a);
max:=a;
min:=a;
for i := 1 to n-1 do
begin
write('Введите число: ');
readln(a);
if a>max then max:=a;
if a<min then min:=a
end;
writeln('Максимальное число в последовательности: ',max);
writeln('Минимальное число в последовательности: ',min)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота