В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
steshina27
steshina27
13.04.2023 05:17 •  Информатика

Нужна ваша ! в необходимо составить программу на алгоритмическом языке visual basic в excel.причем, программа должна быть записана в двух вариантах: в первом варианте необходимо использовать оператор условного перехода tо, а во втором операторы цикла , next.сама : составить программу расчета доз внесения минеральных удобрений под запланированный урожай (кг действующего вещества на 1 га) по формуле: д=(в/к1)+((сз-сф)*к2)/(к3*т),где в -вынос питательного вещества запланированным урожаем, кг/га; к1 - коэффициент использования растениями питательного вещества удобрений; сз - заданное содержание питательного вещества в почве, мг на 100 г; сф -фактическое содержание питательного вещества в почве, мг на 100 г; к2 - коэффициент пересчета мг на 100 г в кг/га; к3 - коэффициент влияния удобрения на содержание питательного вещества в почве; т -время, за которое намечено получить заданное содержание питательных веществ в почве. фактическое содержание питательного вещества в почве меняется в пределах от 10 до 25 мг на 100 г с шагом 1 мг. заранее ! ​

Показать ответ
Ответ:
Монтер111
Монтер111
22.06.2021 16:42

1) 89₁₀ = 1011001₂

2) 600₁₀ = 100101100₂

3) 2010₁₀ = 11111011010₂

1) 513₁₀ = 1001₈

2) 600₁₀ = 1130₈

3) 2010₁₀ = 3732₈

Объяснение:

1)

89 / 2 = 44 + остаток 1

44 / 2 = 22 + остаток 0

22 / 2 = 11 + остаток 0

11 / 2 = 5 + остаток 1

5 / 2 = 2 + остаток 1

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

89₁₀ = 1011001₂

2)

600 / 2 = 300 + остаток 0

300 / 2 = 150 + остаток 0

150 / 2 = 75 + остаток 0

75 / 2 = 37 + остаток 1

37 / 2 = 18 + остаток 1

18 / 2 = 9 + остаток 0

9 / 2 = 4 + остаток 1

4 / 2 = 2 + остаток 0

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

600₁₀ = 100101100₂

3)

2010 / 2 = 1005 + остаток 0

1005 / 2 = 502 + остаток 1

502 / 2 = 251 + остаток 0

251 / 2 = 125 + остаток 1

125 / 2 = 62 + остаток 1

62 / 2 = 31 + остаток 0

31 / 2 = 15 + остаток 1

15 / 2 = 7 + остаток 1

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

2010₁₀ = 11111011010₂

1)

513 / 8 = 64 + остаток 1

64 / 8 = 8 + остаток 0

8 / 8 = 1 + остаток 0

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

513₁₀ = 1001₈

2)

600 / 8 = 75 + остаток 0

75 / 8 = 9 + остаток 3

9 / 8 = 1 + остаток 1

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

600₁₀ = 1130₈

3)

2010 / 8 = 251 + остаток 2

251 / 8 = 31 + остаток 3

31 / 8 = 3 + остаток 7

3 / 8 = 0 + остаток 3

записываем остатки снизу вверх

2010₁₀ = 3732₈

0,0(0 оценок)
Ответ:
vavkina2016
vavkina2016
23.07.2020 12:12

Вопрос скорее будет звучать "как много могли съесть толстяки?".

#include <iostream>

using namespace std;

int main() {

int multiplier = 1;

float weightCake = 0;

float t1(0), t2(0), t3(0);

float t1Cakes(0), t2Cakes(0), t3Cakes(0);

cout << "Weight of cake, fat people 1-3: ";

cin >> weightCake; cin >> t1; cin >> t2; cin >> t3;

while(1) {

t1Cakes = multiplier * weightCake * 1;

if(t1Cakes > t1/2) {

    cout << multiplier - 1;

    break;

}

t2Cakes = multiplier * weightCake * 2;

   if(t2Cakes > t2/2) {

 cout << multiplier - 1;

    break;

   }

t3Cakes = multiplier * weightCake * 4;

   if(t3Cakes > t3/2) {

    cout << multiplier - 1;

    break;

   }

++multiplier;

}  

}


Нужно решить задачку на C++ Трем толстякам подали на десерт кремовые пирожные. Масса одного пирожног
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота