В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anjela2288
anjela2288
20.06.2022 06:58 •  Информатика

нужно написать код на Python вот сама задача Дано целое число N (> 0).
Найти двойной факториал N: N!! = N * (N-2) * (N-4)*

Показать ответ
Ответ:
свайпер
свайпер
22.03.2023 01:40
Если взглянуть на мировую историю, то становится понятным, что человечество постоянно развивается, улучшая технологии, обогащая свой опыт и знания. И то, что ещё недавно казалось чем-то невероятным, уже через пару десятков лет воспринимается как нечто вполне обыденное.Именно так компьютеры, появившись сравнительно недавно, прочно вошли в нашу повседневную жизнь, точно так же, как полиэтиленовые пакеты или телевидение. Сегодня не иметь дома этого высокотехнологичного устройства считается едва ли не дурным тоном. Хотя для многих вопрос о том, зачем же нужен ПК, до сих пор остаётся открытым.В первую очередь необходимо вспомнить о том, что эта железная коробка для немалой части населения является единственным источником заработка. Безусловно этому ещё одно изобретение человечества – Интернет. Виртуальный мир предлагает пользователям самые разные возможности заработка, от написания текстов до создания или продвижения сайтов. Достаточно много специалистов, которые прекрасно себя чувствуют в статусе фрилансеров и занимаются такими вещами, как: проведение онлайн-обучения, разработка бренда компании и многими другими.
0,0(0 оценок)
Ответ:
Голес
Голес
14.06.2022 07:13

Если движение (0; 0) -> (0; 1) - это движение вверх по ОY, то поворот на 90 градусов против часовой стрелки даёт R.

Код:

def invert_path(d: str):

   r = {

       "L": "R",

       "R": "L",

   }

   return r[d]

def dragon(depth: int) -> str:

   if depth == 1:

       return

   yield from dragon(depth-1)

   yield "R"

   second_part = dragon(depth-1)

   yield from (invert_path(x) for x in reversed(list(second_part)))

n = int(input())

print("".join(dragon(n)))

===================================

Если ответ удовлетворил, не забудь отметить его как "Лучший".


Написать программу на питонПостроение кривой дракона Кривая дракона — один из наиболее известных фра
Написать программу на питонПостроение кривой дракона Кривая дракона — один из наиболее известных фра
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота