В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sok6
sok6
01.10.2022 05:30 •  Информатика

Нужно написать на паскале. напишите программу которая задевает массив из n элементов случайными целыми числами в диапазоне [а, в] и определяет количество чисел в массиве у которых в 6-ричной системе счисления встречается цифра 3.

Показать ответ
Ответ:
Паралиллепипед
Паралиллепипед
24.06.2021 06:41
Программа может выглядеть так:

uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
    i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to  n do
   begin
   A[i]:=10+random(90);
   Write (A[i]:5);
   end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
  if A[i]<Min then
     begin
       Min:=A[i];
       MinInd:=i;
     end
     else
       if A[i]>Max then
       begin
       Max:=A[i];
       MaxInd:=i;
     end;
end;
 temp:=A[MaxInd];
 A[MaxInd]:=A[MinInd];
 A[MinInd]:=temp;
 WriteLn;WriteLn;
 for i:=1 to  n do
   Write (A[i]:5);
 WriteLn;
 ReadLn;
end.
0,0(0 оценок)
Ответ:
Любимая0105
Любимая0105
24.06.2021 06:41
Программа может выглядеть так:

uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
    i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to  n do
   begin
   A[i]:=10+random(90);
   Write (A[i]:5);
   end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
  if A[i]<Min then
     begin
       Min:=A[i];
       MinInd:=i;
     end
     else
       if A[i]>Max then
       begin
       Max:=A[i];
       MaxInd:=i;
     end;
end;
 temp:=A[MaxInd];
 A[MaxInd]:=A[MinInd];
 A[MinInd]:=temp;
 WriteLn;WriteLn;
 for i:=1 to  n do
   Write (A[i]:5);
 WriteLn;
 ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота