В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dimaalexandrovi
dimaalexandrovi
11.05.2020 20:39 •  Информатика

нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0,2< =sin ai < =0,5, i=1, n

Показать ответ
Ответ:
AnnaLOVEannaLOVEanna
AnnaLOVEannaLOVEanna
27.06.2020 11:35
#include <iostream>
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {  
  b=f[i];
if(-0.2<=sin(b)<=0.5)
{       
   k++;  cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота