В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
moxowa81
moxowa81
09.02.2020 10:52 •  Информатика

Нужно написать программу на pascal abc net. суть программы такова, чтобы она рандомно выбирала цвета (красный, чёрный или зелёный), но с определёнными шансами, то есть красный=43,75%, чёрный=50% и зелёный=6,25%. в результате программа должна выдать человеку какой цвет выпадет. в множество красного цвета входят числа: 1,5,7,9,11,13,15 в множество чёрных: 2,4,6,8,10,12,14,16 в множество зелёных: 3.

Показать ответ
Ответ:
kseniazorina14
kseniazorina14
26.08.2020 23:25
Считая, что функция random() возвращает случайные числа с равномерным законом распределения и что 7/16*100 = 43,75, 8/16*100 = 50, 1/16 = 6,25, задачу можно решить так:
begin
 var c:=random(1,16);
 case c of
  1,5,7,9,11,13,15: writeln(c,' - Красный');
  2,4,6,8,10,12,14,16: writeln(c,' - Чёрный');
  else writeln(c,' - Зелёный');
  end;
end.

Пример:
7 - Красный
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота