Нужно написать программу на pascal abc net
Текстовый файл содержит строки различной длины. Общий объём файла не
превышает 1 Мбайт. Строки содержат только заглавные буквы латинского
алфавита (ABC…Z). Определите количество строк, в которых буква E
встречается чаще, чем буква A.
и действуем по указанному правилу:
берём букву из слова и по алфавиту смотрим, какая буква идёт третьей после нашей буквы
если упёрлись в конец алфавита- продолжаем счёт с начала алфавита (движемся по кругу)
чтобы это было удобнее, я запишу алфавит сразу с добавленными буквами в его конце:
такое действие выполняем для каждой буквы в слове
Итак, шифруем слова:
ИНФОРМАЦИЯ => ЛРЧСУПГЩЛВ
КОМПЬЮТЕР => НСПТБХЗУ
ЧЕЛОВЕК => ЪЗОСЕЗН
А вообще, для человека такое преобразование не очень удобно делать, поэтому для большего объёма текста проще было бы составить программу, или таблицу в Экселе, которая бы выполняла нужные действия с текстом.
x,y:integer;
vcp,dx,dy:real;
begin
Write('Возраст Тани='); Read(x);
Write('Возраст Мити='); Read(y);
vcp:=(x+y)/2;
dx:=x-vcp; dy:=y-vcp;
Writeln('Средний возраст равен ',vcp);
if dx>0 then begin
Writeln('Таня старше среднего возраста на ',dx,' лет,');
Writeln('а Митя младше среднего возраста на ',-dy,' лет.')
end
else
if dx=0 then Writeln('Таня и Митя ровесники')
else begin
Writeln('Таня младше среднего возраста на ',-dx,' лет,');
Writeln('а Митя старше среднего возраста на ',dy,' лет.')
end
end.
Тестовое решение:
Возраст Тани=15
Возраст Мити=12
Средний возраст равен 13.5
Таня старше среднего возраста на 1.5 лет,
а Митя младше среднего возраста на 1.5 лет.