В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dashasamoylova2
dashasamoylova2
08.05.2022 02:19 •  Информатика

Нужно написать программу на языке паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

Показать ответ
Ответ:
Alina2006mark
Alina2006mark
04.10.2020 15:29
Var a,p,n,i:integer;
begin
 p := 0;
 n := 0;
 for i := 1 to 15 do
  begin
  read(a);
  if a mod 3 = 0 then
    if a > 0 then p := p + 1
    else
    if a < 0 then n := n + 1
  end;
  if p > n then writeln('Положительных') else
  if p < n then writeln('Отрицательных') else
    writeln('Одинаково')
end.

{вариант "как-то посложнее"}

var a,i,s:integer;
begin
 s := 0;
 for i := 1 to 15 do
  begin
  read(a);
  s := s + ord(a mod 3 = 0) * (ord(a > 0) - ord(a < 0))
  end;
 if s > 0 then writeln('Положительных') else
 if s < 0 then writeln('Отрицательных') else
 writeln('Одинаково')
end.   
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота