В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
iirunka153
iirunka153
03.12.2020 23:21 •  Информатика

Нужно написать программу паскаль.. 7.62. даны натуральное число n и целые числа a1, a2, a3, …a9. найти: а) номер максимального из чисел ai,. если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Показать ответ
Ответ:
ваня1340
ваня1340
25.05.2020 12:55

program asd;
uses crt;
var
i:integer;
a: array[1..9] of integer;
naibnum:integer;
naib:integer;
naim:integer;
naimnum:integer;
begin
writeln('Вводите цифры');
for i:=1 to 9 do
begin
readln(a[i]);

if i = 1 then naim:=a[i];
if i = 1 then naib:=a[i];
if a[i] < naim then
begin
naim:=a[i];
naimnum:=i;
end;

if a[i] > naib then
begin
naib:=a[i];
naibnum:=i;
end;
end;

writeln('Наименьшее:',naim, ' номер:', naimnum);
writeln('Наибольшее:',naib, ' номер:', naibnum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота